YOUR NEW SOFTWARE'S
MINIMUM SYSTEM REQUIREMENTS
Not sure whether your operating system can handle our software?
Check out the information below to learn more about software and operating system compatibility!

OPERATING SYSTEM

WINDOWS 10 & 11 – 64 BIT

FOR CAD PLATFORMS

null

BENTLEY

MicroStation V8i & Connect,
PowerDraft V8i & Connect

null

AUTODESK

AutoCAD, AutoCAD Map, Civil 3D
Version 2017 to 2022 64-bit

null

BRICSYS

BricsCAD V21
& V22 64-bit

STILL NEED TO GET IN TOUCH WITH OUR TEAM?